I have always wondered if it is better to name a class as DBStuff or DbStuff.
I just noticed that ADO.NET uses DbCommand, DbConnection etc. so it is pretty clear that it should be DbStuff. Funny I never noticed it before. However if all you need to call it is DB .. then all uppercase is the convention (All Uppercase for abbreviations that are 1 or 2 characters long e.g. Math.PI otherwise Pascal case e.g. Guid )
Verified from Source: http://www.csharpfriends.com/articles/getarticle.aspx?articleid=336
"Only use all upper case for identifiers if it consists of an abbreviation which is one or two characters long, identifiers of three or more characters should use Pascal Casing instead."